The web application (mixpanel.com) should now be recovered. Scheduled maintenance is currently in progress, and some functionality may be intermittently unavailable. We will provide updates as necessary.
Posted Aug 07, 2025 - 15:33 PDT
Update
The maintenance is ongoing, and you may experience issues loading mixpanel.com at this time. Our engineering team is actively working on it. We will post additional updates as the maintenance proceeds.
Posted Aug 07, 2025 - 15:11 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 07, 2025 - 15:00 PDT
Scheduled
Mixpanel will be performing a database maintenance on Thursday, August 7th, between 3PM and 5PM Pacific Daylight Time (UTC-7).
During the maintenance, there may be a brief period where the Mixpanel Webapp may not be accessible, degraded Query API performance, and ingestion may be delayed. We anticipate that there will be no data loss.
We will post progress updates on our status page. If you have any questions, please contact support.
Please Note: The next maintenance will occur on Friday, August 8th, between 12PM and 5PM PT.