Issues loading the Users report
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted May 13, 2022 - 06:17 PDT
Investigating
We have identified an issue when loading the Users page for a subset of projects. We are currently investigating the causes.
Posted May 12, 2022 - 23:58 PDT
This incident affected: Website.