Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 10, 2026 - 17:00 PDT
Scheduled
Mixpanel will be performing database maintenance on Friday, April 10, from 5:00 PM – 5:30 PM PDT (April 11, 12:00 AM – 12:30 AM UTC).
During the maintenance, Mixpanel's Web Application, MCP, Warehouse Connectors, Data Pipelines, Cohort Syncs, GDPR API, Query API, and Raw Export API may be temporarily unavailable. We expect no Ingestion API downtime and no data loss.
If requests to MCP, GDPR API, Query API, or Raw Export API fail during the maintenance window, please retry them once the window has concluded. Ongoing Cohort Syncs, Data Pipeline runs, and Warehouse Connector jobs that fail will automatically retry after maintenance is complete.
We will post progress updates on our status page. If you have any questions, please contact support.
Posted Apr 07, 2026 - 15:53 PDT
This scheduled maintenance affected: Application Availability (Application Availability (US), Application Availability (EU), Application Availability (IN)) and Data Export.