Degraded WebApp Performance
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 17:20 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 01, 2024 - 17:11 PST
Investigating
We are experiencing degraded performance loading pages in our WebApp.
We appreciate your patience while our engineers work to restore normal functionality. If you have any questions, please contact support
Posted Feb 01, 2024 - 16:24 PST
This incident affected: Website.