Errors loading Mixpanel.com
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Feb 07, 2023 - 21:44 PST
Update
We are continuing to monitor for any further issues with loading mixpanel.com.
Posted Feb 07, 2023 - 16:53 PST
Update
We are continuing to monitor the ongoing loading issues affecting mixpanel.com.
Posted Feb 07, 2023 - 13:20 PST
Update
Mixpanel is experiencing intermittent loading issues. We are continuing to work on a fix for this issue.
Posted Feb 07, 2023 - 10:32 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2023 - 09:34 PST
Investigating
We are currently investigating an issue affecting mixpanel.com (both marketing site and reports are affected)
We will keep sharing updates at mixpanelstatus.com
Posted Feb 07, 2023 - 09:02 PST
This incident affected: Website.