Ingestion Data Delay
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Oct 18, 2016 - 10:26 PDT
Identified
Due to server maintenance, Engagement reports may not reflect the most up to date data. No data is being lost, and our engineers are working to restore realtime reporting. If you have any questions, please contact support@mixpanel.com
Posted Oct 18, 2016 - 08:55 PDT