Board Access Issues

Incident Report for Mixpanel

Resolved

This incident has been resolved.
Posted May 19, 2026 - 14:18 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 19, 2026 - 13:23 PDT

Identified

The issues has been identified and a fix is being implemented. As a workaround boards can be explicitly shared with users who are having issues viewing them currently.
Posted May 19, 2026 - 12:10 PDT

Investigating

A subset of users are currently facing issues accessing boards that they previously had access to view. Our Engineering team is actively investigating and will update shortly.
Posted May 19, 2026 - 12:03 PDT