Elevated errors in projects with EU residency

Incident Report for Mixpanel

Resolved

This incident has been resolved.
Posted Dec 19, 2024 - 07:00 PST

Investigating

We're experiencing an elevated level of errors in loading reports for projects with EU data residency and are currently looking into the issue.
Posted Dec 19, 2024 - 06:05 PST