Loading issue with Navigation Bar
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted May 03, 2022 - 11:51 PDT
Investigating
We are currently investigation the issue that is causing the nav bar to no load report options on the drop-down menu and the Applications icon.
Posted May 03, 2022 - 11:23 PDT
This incident affected: Website.