Increased latency loading pages in Mixpanel WebApp
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Aug 23, 2021 - 13:09 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 23, 2021 - 08:38 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 23, 2021 - 08:05 PDT
Investigating
We are experiencing increased latency loading pages in our WebApp.
We appreciate your patience while our engineers work to restore normal functionality. If you have any questions, please contact support
Posted Aug 23, 2021 - 07:27 PDT
This incident affected: Website.