Query Data Discrepancies

Incident Report for Mixpanel

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 03:55 PST

Monitoring

Our Engineering team has identified the issue and deployed a fix - we will continue to review its performance and post another update if any instability reappears or when the problem is fully resolved
Posted Dec 09, 2025 - 01:05 PST

Investigating

We are currently experiencing query data discrepancies and are working to restore service as quickly as possible. Our team is investigating the issue and will provide updates as soon as we have more information. Thank you for your patience.
Posted Dec 09, 2025 - 00:41 PST