Issue with Inviting and Deleting Users

Incident Report for Mixpanel

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 14:27 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 03, 2026 - 13:17 PDT

Investigating

Mixpanel is currently experiencing a disruption in the ability to invite and delete internal users within organizations. We appreciate your patience while our engineers work to restore this functionality. If you have any questions, please contact support@mixpanel.com
Posted Jun 03, 2026 - 13:05 PDT