Degraded Query API performance impacting US reports
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 17:33 PDT
Monitoring
A fix was implemented, and reports should now be loading. We are monitoring the results.
Posted Mar 22, 2024 - 16:56 PDT
Identified
The issue has been identified, and a fix was implemented.
Posted Mar 22, 2024 - 16:24 PDT
Investigating
Mixpanel is experiencing degraded Query API performance, causing latency or timeouts when loading data in reports. This is currently affecting US projects.

We truly appreciate your patience and apologize for the inconvenience. If you have any questions, please contact support
Posted Mar 22, 2024 - 16:13 PDT
This incident affected: Query API.