Temporary Email Notification Delay
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Feb 19, 2017 - 18:25 PST
Identified
Email Notifications are currently delayed. We appreciate your patience while our engineers work to reduce the notification queue. If you have any questions, please contact support@mixpanel.com.
Posted Feb 19, 2017 - 14:06 PST