Degraded MCP Availability

Incident Report for Mixpanel

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 17:43 PST

Update

We have partially mitigated the issue and are continuing to monitor for any further impact. We are also actively working to address the root cause.
Posted Mar 02, 2026 - 12:08 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2026 - 11:42 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 02, 2026 - 11:39 PST

Investigating

A subset of users are experiencing OAuth issues when connecting to our MCP server. We are currently investigating this issue.
Posted Mar 02, 2026 - 11:37 PST