Errors loading eu.mixpanel.com (customers on Data Residency in EU)
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Nov 04, 2021 - 12:01 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2021 - 09:59 PDT
Investigating
We have identified issues loading eu.mixpanel.com; this would affect customers with projects on EU residency and being able to load the web app. We are working to restore service as quickly as possible.
Posted Nov 04, 2021 - 09:15 PDT
This incident affected: Website.