Degraded API Performance for queries outside Mixpanel.com
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Jun 14, 2021 - 11:34 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2021 - 09:22 PDT
Identified
The issue has been identified and queries should be recovering. The engineering team is still reviewing this.
Posted Jun 14, 2021 - 09:09 PDT
Update
The engineering team is currently dividing into the root cause of the issue. At this time, a small subset of UI queries (reports loaded in the web app) are also being affected. The team is working on identifying the issue. We will keep providing updates soon while the investigation is ongoing.
Posted Jun 14, 2021 - 08:38 PDT
Investigating
We are currently experiencing additional latency on queries made directly to our HTTP API (mixpanel.com/api/2.0); this is currently not affecting reports within the web app (mixpanel.com) but can cause external scripts that extract data from the API to time out. Our engineers are currently reviewing this to solve the situation as quickly as possible.

We truly appreciate your patience and apologize for the inconvenience. We will post additional updates as soon as possible.
Posted Jun 14, 2021 - 08:06 PDT
This incident affected: Query API.