Issue with Loading Users report
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted May 26, 2022 - 09:29 PDT
Identified
We are currently experiencing issues while loading the Users report in the UI. Although the users are loading the issue affects when adding or sorting columns in the report. We appreciate your patience while our engineers work to restore functionality.
Posted May 26, 2022 - 07:46 PDT