Data Volume Monitoring degraded performance

Incident Report for Mixpanel

Resolved

This incident has been resolved.
Posted May 14, 2026 - 06:35 PDT

Update

We are continuing to work on a fix for this issue.
Posted May 13, 2026 - 14:40 PDT

Identified

Data Volume Monitoring is again experiencing degraded performance due to a recurring upstream provider disruption. We're mitigating now.
Posted May 13, 2026 - 09:34 PDT