Errors loading reports

Incident Report for Mixpanel

Resolved

This incident has been resolved.
Posted Feb 22, 2023 - 00:12 PST

Investigating

Some projects might be running into loading errors for multiple reports within the same project. Not all projects are affected. We are currently investigating the issue.
Posted Feb 21, 2023 - 23:16 PST