Degraded Query API Performance impacting EU Projects

Incident Report for Mixpanel

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 14:47 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 16, 2026 - 12:29 PDT

Identified

Mixpanel is experiencing increased query latency for projects with EU residency, which may result in HTTP 500 responses when querying or saving reports. Projects with US and IN residency remain unaffected. Our engineering team is working on a resolution.
Posted Mar 16, 2026 - 09:50 PDT
This incident affected: Application Availability (Application Availability (EU)).