Data Volume Monitoring degraded performance

Incident Report for Mixpanel

Resolved

This incident has been resolved.
Posted May 12, 2026 - 14:14 PDT

Monitoring

A fix has been implemented, and we are monitoring the result.
Posted May 12, 2026 - 12:59 PDT

Identified

An upstream service provider outage is causing this issue. We are deploying a fix to mitigate the disruption.
Posted May 12, 2026 - 10:46 PDT

Investigating

We are currently investigating an issue that leads to degraded performance of Data Volume Monitoring in a subset of US-based projects. We truly appreciate your patience and apologize for the inconvenience. If you have any questions, please contact support (https://mixpanel.com/get-support).
Posted May 12, 2026 - 10:17 PDT
This incident affected: Application Availability (Application Availability (US)).