Degraded API Performance Impacting Reports for a Subset of Projects
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Mar 19, 2021 - 12:36 PDT
Update
We are seeing stability across all projects and no further issues with functionality have been reported. Should you still experience issues loading reports, please contact support@mixpanel.com.
Posted Mar 19, 2021 - 07:16 PDT
Update
We're seeing improved performance and stability across all projects. We will continue to monitor closely and post updates.
Posted Mar 18, 2021 - 21:26 PDT
Update
A fix has been implemented and we are seeing functionality improving for most projects. There are still some projects with degraded performance that we're working to address and we continue to monitor the situation closely.
Posted Mar 18, 2021 - 13:49 PDT
Update
This issue is ongoing, we are also seeing it affect delivery of messages & A/B tests, cohort syncs, email digests, custom alerts, data pipelines and raw data export. Ingestion is not affected.
Posted Mar 18, 2021 - 10:04 PDT
Monitoring
Our engineering team has identified the issue as rate limits from Google Cloud Storage. Google Cloud Support has updated us with a timeline of 1:00 PM CT (11:00AM PT) for an estimated fix. We are waiting for confirmation from Google for this and are closely monitoring the issue.
Posted Mar 18, 2021 - 08:27 PDT
Identified
The issue has been identified and our engineering team is working on a fix.
Posted Mar 18, 2021 - 08:05 PDT
Investigating
A subset of projects are experiencing issues loading reports and exporting data through the API endpoint mixpanel.com/api/2.0/. Our engineers are working to fix this issue as quickly as possible.

We truly appreciate your patience and apologize for the inconvenience. If you have any questions, please contact support@mixpanel.com.
Posted Mar 18, 2021 - 05:57 PDT
This incident affected: Website and Query API.