Errors loading Mixpanel.com
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Dec 19, 2022 - 13:54 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 19, 2022 - 08:28 PST
Investigating
We have identified issues loading mixpanel.com for a subset of our customers and we are working to restore service as quickly as possible.
Posted Dec 19, 2022 - 07:49 PST
This incident affected: Website.