Mixpanel MCP: Get-Report degraded

Incident Report for Mixpanel

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 06:32 PDT

Monitoring

A fix has been deployed and we're now monitoring the results. Report queries in the Mixpanel MCP server should be functioning normally. We'll continue to watch closely and provide a final update once we've confirmed full resolution.
Posted Aug 06, 2026 - 02:12 PDT

Identified

The issue has been identified and fix is being implemented.
Posted Aug 06, 2026 - 01:39 PDT

Investigating

We are aware that the Get-Report tool in the Mixpanel MCP server is currently failing when called with skip_results: false. Report metadata is unaffected. We are investigating the issue and will provide updates as we have them.
Posted Aug 06, 2026 - 00:19 PDT
This incident affected: Application Availability (Application Availability (US), Application Availability (EU), Application Availability (IN)).