Mixpanel.com is up and running again. We continue to monitor the performance and its stability, but for now, we are not experiencing any further latency.
Posted Aug 11, 2025 - 04:41 PDT
Monitoring
We're continuing to work together with the downstream provider and are seeing a recovery of the latency. Error rates for loading reports dropped to nearly 0. We are monitoring the performance for now and will update once the issue has been resolved completely.
Posted Aug 11, 2025 - 03:51 PDT
Update
We have requested a capacity increase with the downstream provider. The latency remains high, but the loading issues occur only intermittently now.
Posted Aug 11, 2025 - 03:19 PDT
Identified
We're continuing to see degraded query performance. The issues we're seeing are due to a latency with a downstream provider. The provider has been contacted and is investigating. We're continuing to work with our provider to resolve these issues.
Posted Aug 11, 2025 - 02:37 PDT
Investigating
We are currently experiencing issues with loading Mixpanel.com and are working to restore service as quickly as possible. Our team is investigating the issue and will provide updates as soon as we have more information. Thank you for your patience.