Mixpanel.com is operating normally and queries have recovered. Our engineering team continues to monitor the situation
Posted Jul 31, 2025 - 15:30 PDT
Update
The maintenance is ongoing and we have detected issues loading mixpanel.com. Our engineering team is actively working on it. We will post additional updates as our team continues to work on it
Posted Jul 31, 2025 - 15:20 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 31, 2025 - 15:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 30, 2025 - 16:39 PDT
Scheduled
We are performing a scheduled database maintenance from 3PM to 5PM PDT on July 31st. There may be a brief ingestion delay via our SDKs, and intermittent errors in our [/import API endpoint](https://developer.mixpanel.com/reference/import-events). Possible difficulties in querying real-time data via our webapp are expected during this time. We will post progress updates on our [status page](https://mixpanelstatus.com/). If you have any questions, please contact [support](https://mixpanel.com/get-support).
The next maintenance will occur on August 8th between 12PM and 5PM.
Posted Jul 30, 2025 - 13:46 PDT
This scheduled maintenance affected: Application Availability (Application Availability (US), Application Availability (EU), Application Availability (IN)) and Data Ingestion (Ingestion API Availability (US), Ingestion API Availability (EU), Ingestion API Availability (IN), Warehouse Connectors).