Degraded Query API Performance impacting US Projects

Incident Report for Mixpanel

Resolved

This incident has been resolved.
Posted Jan 24, 2026 - 10:00 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 24, 2026 - 08:28 PST

Update

We are continuing to work on a fix for this issue.
Posted Jan 24, 2026 - 08:02 PST

Identified

Mixpanel is experiencing degraded Query API performance, resulting in HTTP 500 responses when querying or saving reports for projects with US residency. Projects with EU and IN residency remain unaffected. Our engineering team is working on a resolution.
Posted Jan 24, 2026 - 06:25 PST