Degraded Query API performance impacting US reports
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Apr 05, 2023 - 20:30 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 05, 2023 - 17:28 PDT
Update
We are continuing to investigate this issue.
Posted Apr 05, 2023 - 16:50 PDT
Investigating
Mixpanel is experiencing degraded Query API performance, causing latency or timeouts when loading data in reports. This is currently affecting US projects.

We truly appreciate your patience and apologize for the inconvenience. If you have any questions, please contact support
Posted Apr 05, 2023 - 14:49 PDT
This incident affected: Query API.